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EViews在经济计量学中的应用 

第一节    EViews概述 

一、EViews简介 
Econometric Views（经济计量视图），简称 EViews，是美国 QMS 公司

(Quantitative Micro Software Co.，网址为 http://www.eviews.com)开发

的运行于 Windows环境下的经济计量分析软件。EViews是应用较为广泛的经

济计量分析软件——Micro TSP 的 Windows 版本，它引入了全新的面向对象

概念，通过操作对象实现各种计量分析功能。EViews提供了进行复杂数据分
析、回归和预测等的强大工具。在运行Windows操作系统的微机上，我们可
以使用 EViews快速地进行经济计量模型的设立、估计、检验和应用等。 

EViews自 1994年起分别推出了 V1.0、V2.0、V3.0、V3.1和 V4.0等版

本。其中，V1.0、V2.0能运行于 Windows 3.1及以上版本的操作系统中，而

V3.0 以上版本只能在 Windows 95 及以上版本的操作系统中运行。本书以

EViews V3.1为例，并简称为 EViews。 

 

运行 EViews 软件所需的配置为：能运行 Microsoft Windows 

95/98/Me/NT4.0/2000的奔腾级微机；8M或更多的内存，随 Windows的不同

版本而不同；VGA、SVGA或兼容的显卡；与 Windows兼容的鼠标；10M以上的

剩余硬盘空间。 

EViews引入了流行的对象概念，操作灵活简便，可采用多种操作方式进
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行各种计量分析和统计分析，数据管理简单方便。其主要功能有： 

（1）采用统一的方式管理数据，通过对象、视图和过程实现对数据的各种操

作； 

（2）输入、扩展和修改时间序列数据或截面数据，依据已有序列按任意复杂

的公式生成新的序列； 

（3）计算描述统计量：相关系数、协方差、自相关系数、互相关系数和直方

图； 

（4）进行 T检验、方差分析、协整检验、Granger因果检验； 

（5）执行普通最小二乘法、带有自回归校正的最小二乘法、两阶段最小二乘

法和三阶段最小二乘法、非线性最小二乘法、广义矩估计法、ARCH模型估计

法等； 

（6）对二择一决策模型进行 Probit、logit和 Gompit估计； 

（7）对联立方程进行线性和非线性的估计； 

（8）估计和分析向量自回归系统； 

（9）多项式分布滞后模型的估计； 

（10）回归方程的预测； 

（11）模型的求解和模拟； 

（12）数据库管理； 

（13）与外部软件进行数据交换 

 

二、EViews的安装 
如果计算机中还没有安装 EViews，则可以按以下步骤进行安装： 
（一）启动Windows后，把 EViews系统安装盘插入软驱，并找到 EViews
的安装程序文件 Setup.exe。 
（二）双击 Setup.exe文件，安装程序向导将给出每一步操作的提示。在
出现[Welcome（欢迎）]①窗口后，单击[Next]按钮进入下一步。 
（三）安装程序显示[Software License Agreement]对话框时，单击[Yes]
按钮接受显示的协议条款。 
（四）选择 EViews的目标文件夹（即目录），默认文件夹为 C:\EVIEWS3。
如果要改变安装文件夹，单击[Browse]按钮并在子对话框的路径文本框中输
入新的文件夹名称。返回后单击[Next]按钮。 
（五）在[Select Program Folder]窗口中，采用默认的程序快捷方式和图

                                                        
①这里统一用方括号“[  ]”表示按钮名称、菜单项名称或对话框中的标签等。 
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标文件夹[EViews 3]，单击[Next]按钮。 
（六）安装程序把文件复制到目标文件夹。安装过程中若要求插入系统

安装盘，根据提示插入相应的软盘并单击[OK]按钮。 
（七）出现[Setup Complete]窗口，表明安装成功，单击[Finish]按钮结束
安装过程。 

三、EViews的启动、退出和主界面 
（一）启动 EViews：单击 Windows 的[开始]按钮，选择[程序]项中的

[EViews 3]，单击[EViews 3]中的[EViews 3.1]。 
（二）EViews的主界面： 

 

图附-1  EViews主界面 
1．标题栏 
EViews窗口的顶部是标题栏，标题栏左边是控制框。标题栏的右边是控

制按钮，有[最小化]、[最大化（或还原）]和[关闭]三个按钮：。 
2．菜单栏 
标题栏下面是菜单栏。菜单栏上共有 9个主菜单项，即[File（文件）]、

菜

单

栏 

标题栏

工

作

区 

命令窗口

信息框 路径 数据库 工作文件
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[Edit（编辑）]、[Objects（对象）]、[View（视图）]、[Procs（过程）]、[Quick
（快速）]、[Options（选项）]、[Window（窗口）]、[Help（帮助）]。单击
主菜单项时将拉下其子菜单项。 

3．命令窗口 
菜单栏下面是命令窗口（Command Window），窗口闪烁的“|”是光标。

用户可在光标位置用键盘输入各种 EViews命令，并按回车键执行该命令。 
4．工作区窗口 
命令窗口下面是 EViews 的工作区窗口。操作过程中打开的各子窗口将

在工作区内显示。 
5．状态栏 
EViews主窗口的底部是状态栏，从左到右分别为：信息栏、路径框、当

前数据库框和当前工作文件框。 
（三）退出 EViews 
选择[File]=>[Exit]②将退出 EViews，如果工作文件没有保存，系统将提

示用户保存文件。 

四、EViews中的对象概念 
要掌握好 EViews，很重要的一点就是要学会从“对象(object)”的角度来

看待 EViews的各种操作，因为 EViews是根据“面向对象方法”来设计的。 
面向对象方法作为一种新的问题解决方法，对计算机软件的发展起到了

巨大的推动作用。其基本出发点就是尽可能地按照人类认识世界的方法和思

维方式来分析和解决问题。客观世界是由许多具体的事物或事件、抽象的概

念、规则等组成的，因此，我们可将任何感兴趣的或要加以研究的事、物和

概念都统称为对象。例如，宇宙、地球、人、计算机、机器人、数据等都是

对象。对象都有各自的名字，不同类型的对象不应该取相同名字，同一类型

的各个对象也不应该取相同的名字。 
对象都具有状态和特征，可用数据、信息或属性(Property)来描述。例如，

对象“飞机”具有机型、飞行高度、飞行速度等属性。对象还应当有操作（方

法），用以改变对象的状态和特征。从动态的观点来看，对象及其操作就是对

象的行为。例如，对象“飞机”的操作有改变飞行高度、改变飞行方向等。 

                                                        
② 这里把菜单选择简记为[  ]=>[  ]，如[File]=>[Exit]表示：先单击主菜单的[File]项，然
后在其下拉菜单项中单击[Exit]菜单项。 
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EViews采用了与对象、对象的属性和对象的操作方法等类似的概念来描
述数据、数据表现形式和数据操作，EViews中的所有数据信息都存储在对象
中，对数据的操作都可以通过查看其属性或使用其操作方法来实现。EViews
中与对象相关的概念有： 
（一）对象容器（Object Containers） 

对象容器是用于保存和组织对象的,所有对象都必须存放在对象容器

中，其实对象容器本身也是一个对象。EViews 的对象容器有工作文件

(Workfile)和数据库(Database)两种。 

工作文件是最重要的对象容器，任何经济计量分析的第一步都是创建一

个新工作文件或者打开已存在的工作文件。工作文件创建或打开后便一直保

存在内存之中，这使得对工作文件中的对象进行存取的速度更快。每个工作

文件都具有特定的样本数据频率(frequency)和范围(range)。 
数据库与工作文件不同，当存取数据库中的对象时，可以直接对保存在

磁盘上的数据库对象进行存取，而无须把整个数据库装载到内存中。数据库

中的对象可以有不同的数据频率和范围。数据库支持强大的查询功能，适用

于管理大量数据。 
第二节将介绍工作文件的使用，有关数据库的内容请参考帮助文件和用

户手册。 

（二）对象(Objects) 

EViews对象用于保存经济计量分析的信息。根据分析目的不同，可分别

使用不同类型的对象。EViews共有 18种内置对象（如表附-1所示），可分别

完成不同的分析功能，每一种对象类型都有一个固定的类型名称。本附录将

介绍的对象类型有：序列、组、标量、方程、系统、模型等 6种（前三种对

象将在第二节详细介绍，后三种对象将在第三节详细介绍）。通过对这 6种重

要对象的运用，我们就可以完成大部分的经济计量分析功能。 

根据保存信息的不同，对象类型可分为数据对象和非数据对象，例如，

序列、方程和系统等为数据对象，表格、文本和图形等为非数据对象。 

使用具体对象前都必须事先进行定义，即创建对象。我们可以用菜单或

命令行方式来创建对象： 

菜单方式： 

选择[Objects]=> [New Object…]，在对话框中选择对象类型并输入对

象名称。 

命令语法格式： 

对象类型名称  指定的对象名 

其中，对象类型名称只能是表附-1中的一种，对象名由用户指定。例如：

series  y 将创建一个名为 Y的序列对象。 
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创建的对象将在工作文件中显示其对象类型图标和对象名称。除标量对

象外，其它类型的对象均可以打开一个对象窗口（Object Window），用于显

示和分析所含的数据。 

表附-1 EViews对象类型 

图标 对象类型名称及说明 

 Series（序列）：用于保存时间序列数据或截面数据 

 Group（组）：序列或者表达式的集合，不含实际数据 

 Scalar（标量）：用于保存单个数值 

 Equation（方程）：用于单方程的估计、检验和预测等 

 System（系统）：用于联立方程的估计和检验等 
 Model（模型）：用于联立方程的预测和模拟等 

 Graph（图表）：用于代表图形 

 Matrix（矩阵）：用于代表矩阵（二维数组） 

 Pool（数据池）：用于面板数据（包含时序和截面数据）的估计和检验等

 Sample（样本区间）：用于定义样本区间 

 Coef（系数向量）：用于代表方程或系统的系数 
 SSpace（状态空间）：用于动态系统的估计、检验等 
 SYM (Symmetric Matrix)（对称矩阵）：用于代表对称矩阵 
 Table（表格）：表格 
 Text（文本）：文字 
 VAR (向量自回归)：用于向量自回归或误差修正模型 
 Vector（列向量）：用于代表列向量（一维数组） 
 RowVector（行向量）：用于代表行向量（一维数组） 
（三）视图(Views) 

视图以表格和图形窗口的形式提供了查看和分析对象中数据的各种方

法。除标量对象外，其它对象都具有视图。视图相当于一般对象的可视化属

性，EViews对象具有多个属性，因而具有多个视图。例如，序列对象的视图

有：以二维电子表格形式显示数据的[spreadsheet(电子表格)]视图、以线图

显示数据的[line graph（线图）]视图、绘制数据的直方图和计算描述统计

量的[histogram and stats（直方图与统计量）]视图等等。 

视图并不是孤立的，它是相应对象属性的可视化表现。所以，当对象中

的数据发生了变化，该对象的视图将会自动进行更新。对象具有视图，同时

视图也可转换成对象。EViews 允许用户将一个视图转换为一个对象，并将这

样转换而成的对象称为视图的“冻结（freeze）”对象。当相应对象中的数据
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发生变化时，“冻结”对象便不再是其视图，而是一个新的对象，因而将不会

发生变化。 

我们可以通过选择主菜单的[View]项中具体的子菜单，或者单击对象窗

口工具栏上的[View]按钮来打开当前对象的视图。我们也可以用命令打开对

象视图，其对象命令语法格式为：对象名称.视图名称，其中，对象名称必须

是已经创建了的，视图名称通常是一个名词。例如，gdp.sheet 将以表格形

式显示序列对象 gdp的数据。 

（四）过程(Procs/Procedures) 

过程相当于一般对象的操作方法，它与视图相同的地方是，经常在对象

窗口中显示表格或图形；与视图不同的是，过程会改变对象本身的数据，有

的过程甚至可以创建新的对象，而视图则不可以。例如，序列对象的季节调

整过程可对序列数据进行调整并创建一个新对象用以保存调整后的结果。 

我们可以通过选择主菜单的[Procs]项中具体的子菜单，或者单击对象

窗口工具栏上的[Procs]按钮来执行当前对象的各个过程。我们也可以用命令

执行某个过程，其对象命令语法格式为：对象名称.过程名 (选项) 参数，其

中，对象名称必须是已经创建的，过程名通常是一个动词，选项和参数的是

可选的。例如，gdp.seas(m) adjgdp 将按乘方法对序列 gdp进行季节调整并

把结果存为新序列 adjgdp。 

（五）方法(Method) 

不是所有 EViews对象都具有方法，只有 Equation、System、Graph、LogL、

Pool、Sspace、Var 等对象才具有方法。这里的方法专指估计方法，相当于

一般对象的特殊操作方法。例如，方程对象有最小二乘法、加权最小二乘法、

广义矩估计法等各种计量估计方法。 

方法通常在创建对象时设定。对象命令语法格式为：对象名称.方法 (选

项) 参数 。例如：eq1.ls y x （方程 eq1的因变量为 Y，自变量为 X，用最

小二乘法进行估计）。 

（六）数据成员（Data Members） 
数据成员相当于一般对象的属性，是视图中的某个具体项目的取值，通

常是不可见的。数据成员常用于表达式当中，常用@函数给出，其命令语法
格式为：对象名.数据成员。例如：eq1.@r2将返回方程 eq1的判定系数。 
工作文件、对象、视图、数据成员、过程和估计方法等的关系如图附-2

所示。 
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图附-2 EViews对象示意图 

五、EViews的操作方式 
EViews的操作方式可分为交互方式和程序方式，如表附-2所示。 

表附-2  EViews的操作方式 

方式 说明 

 面向对象 面向过程 

菜

单

方

式 

A.对象菜单方式。 

主要通过主菜单[Objects]、

[View]和[Procs]来完成各种操

作，是 EViews推荐使用的菜单方

式。 

B.快速菜单方式。 

通过[Quick]菜单操作。通

过是先选择操作方法，再选择操

作对象。 

交

互

方

式 

命

令

方

式 

C.对象命令(Object Command)方

式。 

与对象菜单相对应的对象命

令及菜单上没有对应项的对象命

令，其功能最强，通常采用“对

象.视图（或过程）”的命令格式，

是 EViews推荐使用的命令方式。

D. 辅 助 命 令 (Auxiliary

Commands)方式。 

与 TSP语法一致的面向过程

命令，通常采用“命令+参数”

的格式。该操作方式主要是为了

与 TSP命令保持一致。 

工作文件（对象容量） 

视图、数据成员 

过程、估计方法 

 
EViews对象 
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示

意

图 

程序 

方式 

通过编程实现重复性批处理操作，或者实现交互方式无法完成的复

杂操作。 

注：交互方式 A和 C具有统一的操作，易触类旁通；方式 B和 D操作方法不

一致，但有时更便捷。四种交互式方式可混合使用，本书主要采用 A、C方式。

下面通过一个简单的统计分析例子介绍四种不同的交互式操作方法，程

序方式见第四节。 

【例附-1】：我国各地区 1998 年人均国内生产总值数据如表附-3所示，用

EViews计算其描述统计量并绘制直方图。 

表附-3  我国各地区 1998年人均 GDP 

地区 人均 GDP 地区 人均 GDP 

北 京 18482.00 湖 北 6300.00 

天 津 14808.00 湖 南 4953.00 

河 北 6525.00 广 东 11143.00 

山 西 5040.00 广 西 4076.00 

内蒙古 5068.00 海 南 6022.00 

辽 宁 9333.00 重 庆 4684.00 

吉 林 5916.00 四 川 4339.00 

黑龙江 7544.00 贵 州 2342.00 

上 海 28253.00 云 南 4355.00 

江 苏 10021.00 西 藏 3716.00 

浙 江 11247.00 陕 西 3834.00 

安 徽 4576.00 甘 肃 3456.00 

福 建 10369.00 青 海 4367.00 

江 西 4484.00 宁 夏 4270.00 

山 东 8120.00 新 疆 6229.00 

河 南 4712.00   

 

（一）对象菜单方式（操作方式 A） 
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1．创建工作文件 

在主菜单中选择[File]=>[New]=>[Workfile]，弹出[Workfile Range]

对话框，在[Workfile frequency]中选择[Undated or irregular]，并在[End 

observation]中输入31，单击[OK]按钮。 
2．创建 Series(序列)对象并录入数据 

选择[Objects]=>[New Object]，显示如下图所示的[New Object（新对

象）]对话框，在[Type of Object（对象类型）]选项中选择[Series（序列）]，

在[Name for Object（对象名称）]键入 GDP，单击[OK]按钮，创建了序列对

象 GDP。 

 
图附-3  创建序列对象 

序列对象 GDP创建后，显示在工作文件中。双击工作文件中的序列 GDP，

打开如图附-14所示的序列对象窗口。单击序列对象窗口上的[Edit +/-]开关
按钮，使序列对象 GDP处于可编辑状态。在序列对象窗口中输入表附-3中的

数据。 



Eviews软件在经济计量学中的应用，张文璋，riskage@sina.com.cn 

 12

 
图附-4  序列对象窗口 

3．查看数据的描述统计量和直方图 

在主菜单或序列对象窗口的工具条中选择[View] =>[Descriptive 

Statistics] =>[Histogram and Stats]，序列对象窗口的视图改为显示直方

图和简单描述统计量，如图附-5所示。 
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图附-5  序列对象直方图及统计量视图 

4．选择[File]=>[Save]或单击工作文件窗口工具栏上的[Save]按钮，在

出现的对话框中输入工作文件名称，单击[Save]保存工作文件。 

（二）快速菜单方式（操作方式 B） 

1．创建工作文件 

同操作方式 A 

2．创建 Series(序列)对象并录入数据 

选择[Quick]=>[Empty Group(Edit Series)]，显示如图附-6所示的空组
对象窗口，自动产生名为 SER01的序列对象。在序列对象窗口中输入表附-3

中的数据。关闭序列对象窗口，在工作文件窗口中右击 SER01，在弹出的快

捷菜单中单击[Rename]，在显示的对话框中输入新的序列名称 GDP，把序列

SER01改名为 GDP。 
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图附-6  输入数据 

3．查看数据的描述统计量和直方图 

 选择[Quick]=>[Series Statistics]=>[Histogram and Stats]，弹出

如图附-7所示的对话框，在[Series name]右框中输入 GDP并单击[OK]按钮。

产生的结果与图附-5相同。 
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图附-7 

4．选择[File]=>[Save]或单击工作文件窗口工具栏上的[Save]按钮，在

出现的对话框中输入工作文件名称，单击[Save]保存工作文件。 

（三）对象命令方式（操作方式 C） 

在命令窗口中输入以下命令：  

create u 1 31(创建工作文件) 
series gdp  （创建序列对象 GDP） 

gdp.sheet   （以电子表格形式查看空 GDP序列对象并录入数据） 

gdp.hist    （查看数据的描述统计量和直方图） 

save gdp   (保存工作文件，文件名为 gdp.wf1) 

（四）辅助命令方式（操作方式 D） 

在命令窗口中输入以下命令： 

create u 1 31(创建工作文件) 
data  gdp （显示如图附-8所示的包括序列 GDP 的空组对象窗口，录入

数据） 
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图附-8 

hist  gdp  （查看数据的描述统计量和直方图，结果同图附-5） 
save gdp   (保存工作文件，文件名为 gdp.wf1) 

操作方式 B和 D的有些命令是相同的，如创建工作文件、保存工作文件、

删除工作文件以及对各种对象复制、删除、改名等操作的命令。 

以上四种交互式操作方法可以混合使用。 

第二节    EViews基本对象 

EViews软件的核心是对象的概念。使用 EViews进行计量分析就是使用
和操纵各种各样的对象。本节将介绍对象容器——工作文件（Workfile）和
最基本的对象——序列对象（Series）、组对象（Group）和标量对象（Scalar）。 

一、工作文件 
（一）创建工作文件 
使用 EViews的第一步就是创建工作文件。其步骤为： 
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选择主菜单[File]=>[New]=>[Workfile]，显示如图附-9所示的对话框。 

 
图附-9 工作文件范围对话框 

在对话框中选择合适的数据频率和起始及结束范围。数据频率各选项

为： 
◎[Annual]表示年度，如 1980、1999、2003等。如果只有两位数，默认

为 20世纪的年份，如 88默认为 1988。 
◎[Semi-annual]表示数据频率为半年。如，起始日期为 2000结束日期为

2002，表示数据范围为 2000:1（上半年）, 2000:2（下半年）, 2001:1, 2001:2, 
2002:1, 2002:2。 
◎[Quarterly]季度，表示为“年:季”或“年.季”，如 2000:3。 
◎[Monthly]月度，表示为“年:月”或“年.月”，如 2000:9。 
◎[Weekly] 、[Daily[5 day weeks]]、[Daily[7 day weeks]]周和日，表示为

“月:日:年” 
◎[Undated or irregular]非时间序列数据，选择该项时，[Start date]和[End 

date]分别改为[Start observation]和[End observation]。 
指定了对话框中的选项和范围后，单击[OK]按钮，就可以看到工作文件

窗口出现在工作区中，如图附-10所示。这时工作文件的文件名为[Untitled]
表示该工作文件未保存和未命名。 
任何新创建的工作文件中都有两个图标： C和 Resid。C表示系数向

量，Resid表示残差序列，C左边的图标 表示对象 C的类型是 Vector，Resid
左边的图标 表示对象 Resid的类型是 Series。 
创建工作文件的命令为： 



Eviews软件在经济计量学中的应用，张文璋，riskage@sina.com.cn 

 18

create  optional_name frequency start end 
其中：optional_name为： 

a Annual. 
s Semi-annual. 
q Quarterly. 
m Monthly. 
w Weekly. 
d Daily (5 day week). 
7 Daily (7 day week). 
u Undated or irregular. 

 
（二）工作文件窗口 

 
图附-10 工作文件窗口 

1．标题栏 
工作文件窗口顶部是标题栏，显示“Workfile：工作文件名”，新创建的

工作文件标题栏显示“Workfile：UNTITLED”表示新创建的工作文件还没有
存盘。标题栏上还有控制工作文件窗口行为的控制框和控制按钮。 

2．工具栏 
标题下面是工具栏，它提供了常用操作的快捷方式。工具栏左边的三个

按钮[View]、[Procs]和[Objects]与主菜单栏上的同名菜单的功能完全一样。 
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3．信息栏 
工具栏下面是信息栏，显示工作文件的范围(Range)、当前样本区间

(Sample)、过滤器(Filter)和默认方程(Default Eq)。当前样本区间是指用于统
计操作的样本观测点范围，它小于或等于工作文件的范围。过滤器是用于选

择一些对象显示在工作文件窗口中的规则，默认为“*”，表示显示全部对象，
如“e*”则表示在工作文件窗口中显示名字以“e”开头的对象。默认方程表
示最近估计过的方程，该工作文件中没有创建过方程则显示“None”。可以
双击这些标签打开相应的对话框或窗口进行修改。 

4．目录 
一般情况下，目录显示工作文件中的所有对象及其图标。双击目录中的

某个对象名称或图标可打开相应的对象窗口。右击某个对象可弹出快捷菜单

选择某种操作。要选择多个对象，按住 Ctrl键的同时单击某个对象。 
（三）保存和打开工作文件 
单击工作文件窗口工具栏上的[Save]按钮或选择[File]=>[Save]把工作文

件保存到磁盘上。也可以选择[File]=>[Save As]把工作文件另存为其它名字的
工作文件。如果在保存工作文件的同时选择[保存类型]为[Old DOS Workfile]
则把工作文件另存为 EViews旧版本和 TSP能够读取的文件，但 EViews中的
一些新对象可能被删除。 
要打开已经保存在磁盘中的工作文件，选择 [File] =>[Open] 

=>[Workfile]，在打开的对话框中找到工作文件并单击[打开]按钮即可。 
保存工作文件的命令为：save  文件名；打开工作文件的命令为：load  

文件名。 
（四）工作文件窗口激活时的主要菜单项 
主菜单栏中的[Objects]、[View]和[Procs]菜单项或对象窗口工具栏上的同

名按钮一样，其下拉菜单项会随着活动对象窗口的不同而改变。当激活工作

文件窗口时，[Objects]、[View]和[Procs]菜单项如下： 
1．[Objects]的菜单项 

◎[New Object…]：创建新的对象。相应的命令为 new。 
◎[Fetch from DB…]：从数据库中加载对象到工作文件中，同工具栏上的

[Fetch]按钮。 
◎[Update selected from DB…]：用数据库中的对象更新所选对象。 
◎[Store selected to DB…]：把所选对象存储到数据库中， 同工具栏上的[Store]
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按钮。 
◎[Copy selected…]：复制所选对象。命令为： 

copy 源对象  目标对象。 
◎[Rename selected…]：重命名所选对象。命令为： 

rename 原对象名 新对象名 
或者 
r原对象名 新对象名。 

◎[Delete selected]：删除所选对象，同工具栏上的[Delete]按钮。命令为： 
 delete 对象名 
 或者 
 d 对象名 

2．[View]的菜单项为： 
◎[Open Selected]=>[One Window]：在一个窗口中打开所选对象，如果选择

了多个类型相同的对象，则让用户选择以何种方式打开。 
◎[Open Selected]=>[Separate Windows]：在单独的窗口中打开所选对象。 
◎[Print Selected]：打印所选对象。 
◎[Show…]：在一个窗口中显示某些对象、对象视图、表达式等，同工具栏

上的[Show]按钮。 
◎[Select All(except C-RESID)]：选择除系数向量 C和残差序列 Resid外的所

有对象。 
◎[Select By Filter…]：通过对象名字过滤器来选择对象。 
◎[Deselect All]：取消所有选择。 
◎[Display Comments (Label+/-)]：显示对象有关注解的开关，同工具栏中的

[Label+/-]按钮。 
◎[Name Display]=>[Uppercase]：目录中的对象以大写字母显示。 

[Name Display]=>[Lowercase]：目录中的对象以小写字母显示。 
◎[Label]：工作文件的有关标签信息。 

3．[Procs]的菜单项为： 
◎[Sample…]：设定样本区间。选择该菜单项时，弹出如图附-11所示的对话
框。在[Sample range pairs]下面文本框中输入样本区间范围，如 1  
31；在[IF condition]下面可根据需要输入条件表达式，通过该表达
式来确定样本区间；两者可同时设定。同工具栏上的[Sample]按钮。
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其命令为： 
smpl 样本区间  或 smpl  样本区间   IF  条件表达式。 

 
图附-11 样本区间对话框 

◎[Change workfile Range…]：弹出如图附-9所示的对话框，改变工作文件的
范围，但不能改变数据频率。其命令为：expand 范围。 

◎[Generate Series…]：通过给定公式计算新序列或一个标量。同工具栏上的
[Genr]按钮。其命令为 genr 对象名=公式。 
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图附-12 生成序列对话框 
◎[Sort Series…]：对一个或多个序列进行排序。其命令为：sort 序列。 

 
图附-13 序列排序对话框 

◎[Import…]：从外部文件（如数据库、文本文件、Excel文件、Lotus文件等）
导入数据。其相应的命令为 read 。 

◎[Export…]：把 EViews 数据导出到其它格式的文件（如文本文件、Excel
文件、Lotus文件等）。其相应的命令为 write 。 

 

二、序列对象 
序列（Series）对象是 EViews中最基本的对象之一，它包含一些观测在

某个变量上的取值。 
（一）序列对象的创建 
创建序列对象的步骤为：选择[Objects]=>[New Object…]，显示如图

附-3所示的[New Object（新对象）]对话框，在[Type of Object（对象类型）]
选项中选择[Series（序列）]，在[Name for Object（对象名称）]键入序列

名称，单击[OK]按钮，即创建了序列对象。 

创建序列对象的命令为： 
series 序列对象名 
创建一空序列，其初始值为“NAs”。例如，series  y。 
series 序列对象名=公式 
根据公式创建一新序列，其初始值为公式的计算结果。例如， 
series y=3*x 。 
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（二）序列对象的视图 
打开序列对象窗口时，[View]的菜单项为： 
◎[SpreadSheet]：以电子表格形式显示序列中的数据，如图附-14所示。

在该视图下，可以对序列中数据进行录入、修改、删除、复制等操作，但在

编辑前要单击工具栏上的[Edit +/-]开关按钮或选择[Objects] =>[View Options] 
=>[Edit +/-]，确保序列对象处于可编辑状态。命令为：序列名.sheet。 

 

图附-14  序列对象窗口 
◎[Line Graph]：显示序列对象的线形图视图。命令为：序列名.line。 
◎[Bar Graph]：显示序列对象的条形图视图。命令为：序列名.bar。 
◎[Descriptive Statistics] =>[Histogram and Stats]：显示序列对象的直方图

和描述统计量视图。命令为：序列名.hist 或 序列名.stats 。 
◎[Descriptive Statistics] =>[Stats by Classification…]：显示根据指定的某

一序列作为分组变量的描述统计量。弹出的对话框如图附-15所示。在
[Series/Group for Classify]下的文本框中输入分组序列，并根据需要改变其它
选项。单击[OK]即可显示该视图。其命令为：序列名.statby (选项) 分组序列
名，其中选项为：sum（显示和）、med（显示中位数）、max（显示最大值）、
min（显示最小值）、skew（显示偏度）、kurt（显示峰度）、na（显示 Nas 的
个数）、nomean（不显示均值）、nostd（不显示标准差）、nocount（不显示个
数）和其它一些控制显示布局等方面的选项。 
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图附-15 分组统计量对话框 

◎[Tests for Descriptive Stats]=>[Simple Hypothesis Tests]：简单的序列分
布假设检验——单样本检验，检验均值、方差或中位数是否与给定的值存在

显著性差异。用户需要在如所示的对话框中指定相应参数。命令为：序列

名.teststat (选项)，其中选项为：mean=指定值（零假设为均值等于该指定值）、
med=指定值（零假设为中位数等于该指定值）或 var=指定的正值（零假设为
方差等于该指定值）、std=指定的正值（已知标准差等于该指定值条件下的均
值检验）或 p（打印出检验结果）。 

 
图附-16 序列分布检验对话框 
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◎[Tests for Descriptive Stats]=>[Equality Tests by Classification]：通过
分组检验不同组之间均值、中位数或方差是否相等——多样本检验。其命令

为：序列名.testby (选项) 序列 1 序列 2 序列 3 ⋯，其中选项包括 mean（默
认选项，检验均值是否相等）、med（检验中位数是否相等）、var（检验方差
是否相等）等等。 

 
图附-17 分组检验对话框 

◎[Distribution Graphs]=>[CDF – Survivor - Quantile]：显示经验的累积分
布函数、生存函数和包括标准误的分位数。相应的命令为 序列名. cdfplot。 
◎[Distribution Graphs]=>[Quantile – Quantile]：绘制某序列的经验分位数

和理论分布的分位数其它序列分位数图形（Q-Q图）。相应的命令为 序列名. 
qqplot。 
◎[Distribution Graphs]=>[Kernel Density]：显示序列的密度函数估计。

相应的命令为 序列名. kdensity 。 
◎[One-Way Tabulation…]：显示一维频数分布表。相应的命令为 序列名. 

freq 。 
◎[Correlogram…]：显示序列的自相关和偏相关图。相应的命令为 序列

名.correl 。 
◎[Unit Root Test…]：单位根检验。相应的命令为 序列名. uroot 。 
◎[Conversion Options…]：设置当序列复制或加载到更高频率的工作文

件中时所使用的频率转换方法。相应的命令为 序列名. setconvert。 



Eviews软件在经济计量学中的应用，张文璋，riskage@sina.com.cn 

 26

◎[Label]：显示序列的标签信息。相应的命令为 序列名.label。 
 
（三）序列对象的过程 
序列对象的过程有： 
◎[Generate by Equation…]：根据其它序列或表达式生成新序列。 
◎[Seasonal Adjustment…]：对序列数据进行季节调整，仅适用于季度和

月度数据。其命令为：序列名.seas （选项） 调整后序列名 调整因素。 
◎[Exponential Smoothing…]：指数平滑。其命令为：序列名.smooth （方

法） 新序列名。 
◎[Hodrick-Prescott (HP) filter…]：获取序列长期趋势的平滑估计的一种

平滑方法。其命令为：序列名.hpf (n,选项) 过滤名。 
 
（四）序列对象的数据成员 
序列对象的数据成员只有一个，即“（i）”，表示序列的第 i 个元素，例

如，gdp(4)表示序列 GDP的第 4个元素，命令 gdp(4)=400把序列 GDP的第
4个元素赋值为 400。 

三、组对象 
组（Group）对象也是 EViews中的基本对象之一。组对象是序列或者表

达式的集合，组对象并不包含实际的序列数据，而只是包括对序列数据的引

用。例如，有一个名为 Group1的组对象，包含序列 ser1、ser2和 ser3，Group1
中只是包含对 ser1、ser2和 ser3的引用指针，实际数据保存在序列 ser1、ser2
和 ser3中。包含一个或多个序列对象的组对象，相当于一张电子表格。 
（一）组对象的创建 
创建组对象的步骤为：选择[Objects]=>[New Object…]，显示如图附-3

所示的[New Object（新对象）]对话框时，在[Type of Object（对象类型）]

选项中选择[Group]，在[Name for Object（对象名称）]键入组对象名称，

单击[OK]按钮，即创建了组对象。 

创建组对象的命令为： 
group 组对象名 
创建一个不含任何序列或表达的空组对象。例如，group  group1创建一

个名为 group1的空组对象。 
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group 组对象名 序列或表达式列表 
根据创建一新组对象，包含序列或表达式。例如， 
group group1 ser1 ser2 ser3 创建包含序列 ser1、ser2 和 ser3 的组对象

group1；group group2 ser1 ser2+ser3创建一个包括序列 ser1和 ser2与 ser3之
和的组对象 group2。 
如果按照创建对象的一般方法，逐个地创建所有序列对象，再创建包含

这些序列对象的组对象，那么该创建过程将是十分繁琐的。实际应用中，可

以使用 data命令来实现： 
data 序列 1  序列 2  序列 3 ⋯ 
该命令将创建序列 1、序列 2、序列 3等序列对象，并创建一个包含这些序列
对象的未命令组对象。 
（二）组对象的视图 
组对象的视图有： 

◎[Group Members]：显示组对象的成员。 
◎[Spreadsheet]：以电子表格形式显示组中各序列或表达式。在该视图下，可
以对组中序列的数据进行录入、修改、删除、复制等操作，但在编辑前要单

击工具栏上的[Edit +/-]开关按钮或选择[Objects] =>[View Options] =>[Edit 
+/-]，确保序列对象处于可编辑状态。组中的表达式结果不同编辑。命令为：
组名.sheet。 
◎[Dated Data Table]：以各种表格形式显示时间序列数据。命令为：组
名.dtable。 
◎[Graph]：显示组中各序列的各种图形： 

[Line]：线形图，命令为：组名.line； 
[Bar]：条形图，命令为：组名.bar； 
[Scatter]：各种散点图，命令为：组名.scat(选项)； 
[XY Line]：X-Y线形图，命令为：组名.xy； 
[Hight-Low(-Close)]：高-低图，命令为：组名.hilo。 
◎[Multiple Graphs]：单独显示组中各序列的各种图形。 

[Line]：线形图，命令为：组名.line(m)； 
[Bar]：条形图，命令为：组名.bar(m)； 
[Scatter]：各种散点图，命令为：组名.scat(m)； 
[XY Line]：X-Y线形图，命令为：组名.xy(m)； 
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[Distribution Graphs]：分布图和 Q-Q图，命令分别为：组名.cdfplot和组
名.qqplot。 

◎[Descriptive Stats]：显示组中序列的描述统计量，命令为：组名.stats。 
◎[Tests of Equality…]：进行均值比较、中位数比较和方差比较等检验，命令
为：组名.testbtw。 
◎[N-Way Tabulation…]：显示 N维交叉表，命令为：组名.freq。 
◎[Correlations]：显示组中各序列之间的相关系数，命令为：组名.cor。 
◎[Covariances]：显示组中各序列之间的协方差，命令为：组名.cov。 
◎[Correlogram(1)…]：显示组中第一个序列的自相关系数、偏相关系数、Q
统计量及其 p值，命令为：组名.correl。 
◎[Cross Correlation (2)…]：显示组中前两个序列的互相关系数，命令为：组
名.cross。 
◎[Cointegration Test…]：协整检验，命令为：组名.coint。 
◎[Granger Causality…]：Granger（格兰杰）因果检验，命令为：组名.cause。 
◎[Label]：显示组对象的标签信息，命令为：组名.label。 
（三）组对象的过程 
◎[Make Equation…]：由组对象创建方程对象，组中第一个序列作为因变量。 
◎[Make Vector Autoregression…]：由组对象创建向量自回归对象。 
（四）组对象的数据成员 
1．(i) 
组中第 i个序列。例如： 
series lny=log(group1(2)) 

将创建一个序列对象 lny，它等于组对象 group1中第 2个序列的自然对数。 
2．@count 
返回组中序列的个数。例如： 

group1.@count 
将返回组对象 group1所含序列对象的个数。 

3．@seriesname(i)  
返回组中第 i个序列对象的名称（字符串）。例如： 

group1.@seriesname(2) 
将返回组 group1中第 2个序列对象的名称。 
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四、标量对象 
标量（Scalar）对象又称为纯量对象，用于保存一个具体的数值，通常用
于表达式中。标量对象是一个较特殊的对象。它的创建方法与一般对象的创

建方法不同，只能在命令窗口中通过键入命令来实现。创建标量对象的命令

格式有： 
scalar 标量对象名  （创建一个值为 0的标量对象） 
标量对象名=值或表达式  （对标量对象赋值） 
scalar 标量对象名=值或表达式  （创建一个值为指定值或表达式计算结果的
标量对象） 
该标量对象名将显示在工作文件目录列表中。 
例如： 
scalar  x 
x=3.14159 
等介于 
scalar x=3.14159 
标量对象没有视图、过程、方法和数据成员，因而也就无法打开其对象

窗口。要显示标量对象的值，可以（1）双击工作文件目录列表中的标量对象，
（2）在命令窗口中输入 show 标量对象名，或者（3）在命令窗口中输入 = 标
量对象名 。标量对象的值将显示在 EViews窗口左下角状态栏的信息框中。 

第三节    EViews估计方法 

一、方程估计法——方程对象 
单方程回归分析是应用范围最广的经济计量方法之一，EViews中采用方

程（Equation）对象进行单方程的估计、检验和预测等。 
（一）方程对象的创建 
用对象菜单方式创建方程对象的基本步骤为：选择[Objects]=>[New 

Object…]，显示如图附-3所示的[New Object（新对象）]对话框，在[Type of 
Object（对象类型）]选项中选择[Equation（方程）]，在[Name for Object

（对象名称）]键入序列名称（如果不输入方程对象名，使用默认名

Untitled），单击[OK]按钮，显示如图附-18所示的方程设定对话框。必须在



Eviews软件在经济计量学中的应用，张文璋，riskage@sina.com.cn 

 30

该对话框中指定四个项目：（1）方程的估计方法，（2）方程的具体形式，（3）

方程的样本估计区间，（4）方程估计时所采用的选项。 

 
图附-18  方程设定对话框 

（1）选择方程的估计方法 

在[Estimate Setting（估计设置）]中的[Method（方法）]下拉列表中，

可以选择方程的估计方法。EViews提供的单方程估计方法有： 

◎LS——最小二乘法，包括普通最小二乘法（OLS）、加权最小二乘法（WLS）、
非线性最小二乘法（NLS）和自回归移动平均(ARMA)； 

◎TSLS——二阶段最小二乘法、二阶段非线性最小二乘法和二阶段自回归移
动平均； 

◎ARCH——自回归条件异方差估计法； 
◎GMM——广义矩估计方法； 
◎Binnary——二值因变量模型估计方法，包括 Probit、Logit和 Gompit（极

端值）等估计方法； 

◎Ordered——定序因变量模型估计方法； 
◎Censored——截断数据模型估计方法； 
◎Count——计数数据模型估计方法。 
不同的估计方法需要提供的参数不同，选择不同估计方法时，方程设定

对话框的具体项目会发生变化。图附-18所示的对话框是选择了“最小二乘法”
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（默认估计方法）时所显示的对话框。 

这里仅介绍“最小二乘法”，下面均假设选择了[LS]估计方法。 

（2）设定方程的具体形式 

在[Equation Specification（方程设定）]下面的文本框中可以指定方

程的因变量、自变量和方程的函数形式。可以采用列表方式或公式方式设定

方程。 

用列表方式设定方程比较简单，但只适用于无约束的线性回归模型。在

[Equation Specification]下面的文本框中输入因变量和自变量。例如，假

设创建了序列对象 Y和 X并录入了相应数据，要估计模型 εβα ++= XY 的系

数，那么在文本框中输入：Y  C  X 。其中，C是 EViews的内置序列对象，

用于指定方程的常数项。前面讲过，工作文件中有一个内置序列对象 C，该

对象就是用列表方式设定方程时所使用的默认系数向量。系数的估计值将存

放在该对象中。本例中，α估计值α̂将保存在 C(1)中，β估计值 β̂ 将保存在

C(2)中。 

设定含滞后序列的线性模型或非线性模型的方程时，可以直接输入因变

量的表达式和自变量的表达式。例如： 

Y C Y(-1) X（Y对常数项、一阶滞后值和变量 X回归）； 
Y C Y(-3) X（Y对常数项、三阶滞后值和变量 X回归）； 
Y C Y(-1 to –3) X(Y对常数项、Y(-1)、Y(-2)、Y(-3)和变量 X回归)； 
Y C X(to –2) （Y 对常数项、X、X(-1)、X(-2)回归，不包括第一个滞后阶
数表示从第 0阶即 X本身开始）； 

LOG(Y) C X（Y的自然对数对常数项和变量 X回归）； 

Y C LOG(X)（Y对常数项和变量 X的自然对数回归）； 

LOG(Y) C LOG(X)（Y的自然对数对常数项和变量 X的自然对数回归）； 

1/Y C X（Y的倒数对常数项和变量 X回归）； 

LOG(Y) C LOG(Y(-1)) ((X+X(-1))/2)（Y的自然对数对常数项、Y一阶滞后

值的自然对数、X的二阶移动平均值回归）。 

用公式方式设定方程比较灵活，适用于线性、非线性、有约束、无约束

的回归模型。方程的公式是由因变量、自变量和系数构成的。要用公式方式

设定方程，只要在文本框中输入方程的公式即可。EViews将自动加上随机扰

动项并用最小二乘法估计模型的系数。事实上，用列表方式设定方程后，
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EViews会自动转换成公式形式再进行估计。例如，EViews将把 

LOG(Y) C LOG(Y(-1)) ((X+X(-1))/2)  

转换为 

LOG(Y)=C(1)+C(2)*LOG(Y(-1))+C(3)*((X+X(-1))/2) 

方程的因变量不一定写在等号的左边，等号可在方程公式的任何位置。

例如，LOG(Y)+C(1)*X=C(2)，这时残差将由下式求得：e=LOG(Y)+C(1)*X-C(2)。 

用公式方式设定方程可估计有约束的回归模型，例如，要限制自变量 X

的各阶滞后值系数之和等于 1，则输入如下公式： 

Y=C(1)+C(2)*X+C(3)*X(-1)+C(4)*X(-2)+(1-C(2)-C(3)-C(4))*X(-3)。 

对于非线性回归模型，只要直接输入公式，EViews将检测其非线性并采

用非线性最小二乘法估计模型系数。例如，Y=C(1)+C(2)*(K^C(3)+L^C(4))。 

（3）方程的样本估计区间 

EViews 在[Sample]右边的文本框中显示工作文作的样本区间作为默认

方程估计区间，可输入新的样本区间进行估计。新的样本区间只影响当前方

程，并不会改变工作文件的当前样本区间。 

（4）方程估计时所采用的选项。 

当[Equation Specification]对话框中的估计方法选择最小二乘法时，

单击[Option（选项）]按钮，将显示如所图附-19示的子对话框。对话框中各

选项的含义为： 

◎选择[Heteroskedasticity Consistent Covariance]和[White]，用 White

方法进行异方差校正。 

◎选择[Heteroskedasticity Consistent Covariance]和[Newey-West]，用

Newey-West HAC方法进行异方差校正。 

这两种方法并不会改变系数的点估计值，只对系数估计的标准误差进行

校正。 

◎选择[Weighted LS/TSLS]并在[Weight]右边的文本框中输入一个序列作为

权数序列，进行加权最小二乘法估计。 

◎[Interative procedure]和[ARMA options]用于控制估计非线性模型时的

迭代过程和设置 ARMA选项。 

设置完估计选项后，单击[OK]按钮返回[Equation Specification]主对

话框。单击主对话框中的[OK]按钮，将创建一方程对象，并显示其估计结果(如

表附-4所示)。 
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图附-19 估计选项对话框 

用对象命令方式创建方程对象的命令为： 

命令格式一： 
equation 方程对象名 
方程对象名.ls（选项） 因变量和自变量列表或公式 
创建一空方程对象，显示在工作文件目录列表中，然后根据给定的因变

量、自变量列表或公式和选项进行估计。选项部分是可选的。以上命令并不

会自动打开方程对象窗口，可输入方程对象名.results显示估计结果。例如， 
equation eq1 
eq1.ls y c x1 x2  
eq1.results 
命令格式二： 
equation 方程对象名.（选项） 因变量和自变量列表或公式 
例如： 

equation eq1.ls y c x1 x2  
eq1.results 
其中，主要选项为： 
w=序列对象号  （以指定序列作为权数序列进行加权最小二乘法） 
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h  （用White方法进行异方差校正） 
n  （用 Newey-West方法进行异方差校正） 
例如如： 
equation eq1.ls (w=w1) y c x 
equation eq1.ls (h) y c x  
 
（二）序列对象的视图 
打开序列对象窗口时，[View]的菜单项为： 

◎[Representations]：以三种形式显示方程，例如： 
Estimation Command: 
LS Y C X 
Estimation Equation: 
Y = C(1) + C(2)*X 
Substituted Coefficients: 
Y = 48985.5991 + 533.7414871*X 

相应的对象命令为：方程对象名.spec或 方程对象名. representations。 
◎[Estimation Output]：显示前面介绍的方程估计结果。也可以单击方程对象
窗口工具栏[Stats]按钮。相应的对象命令为：方程对象名.results或 方程对象
名. stats。 

表附-4  估计输出结果 
Dependent Variable: Y 
Method: Least Squares 
Date: 10/01/00   Time: 11:11 
Sample: 1 10 
Included observations: 10 

Variable Coefficient Std. Error t-Statistic Prob. 

C 48985.60 5685.216 8.616312 0.0000
X 533.7415 165.0580 3.233661 0.0120

R-squared 0.566550     Mean dependent var 67033.00
Adjusted R-squared 0.512369     S.D. dependent var 4904.504
S.E. of regression 3424.845     Akaike info criterion 19.29236
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Sum squared resid 93836493     Schwarz criterion 19.35287
Log likelihood -94.46178     F-statistic 10.45656
Durbin-Watson stat 2.368452     Prob(F-statistic) 0.011991
输出结果解释如下： 
[Dependent Variable]：因变量。 
[Method]：方程估计方法。 
[Date:10/01/00 Time:11:11 ]：输出结果时的日期和时间。 
[Sample]：方程估计时使用的样本区间。 
[Included observations]：观察值个数，即样本容量。 
[Variable]：自变量，其中 C表示常数项。 
[Coefficient]：系数估计值。 

[Std. Error]：系数估计的标准误差，即
)ˆ( jVar β
。 

[t-Statistic]：t统计量值，即
)ˆ(ˆ

jj Var ββ
。 

[Prob].：实际显著性水平（双侧检验），即 p值，当 p值小于给定的显著性水
平α时，拒绝零假设。 

[R-squared]：判定系数
2R 。 

[Adjusted R-squared]：调整后的判定系数
2R
。 

[S.E. of regression （Standard Error of the Regression）]：回归标准误，其计算

公式为
)/( knRSS −
，RSS为残差平方和，n为样本容量，k为待估系数个

数。 
[Sum squared resid]：残差平方和。 
[Log likelihood] ： 对 数 似 然 函 数 值 ， 计 算 公 式 为

[ ])/ln()2ln(1
2

nRSSnl ++−= π
，其中 n为样本容量，RSS为残差平方和。 

[Durbin-Watson stat]：杜宾—瓦森统计量，用于判定扰动项是否存在一阶自相
关。 
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[Mean dependent var]：因变量的均值，计算公式为
nyy

n

i
i∑

=

=
1 。 

[S.D. (Standard Deviation)dependent var]：因变量的标准差，计算公式为

)1()(
1

2 −−= ∑
=

nyy
n

i
yσ

。 

[Akaike info criterion]：AIC 信息准则，用于选择模型。其计算公式为

nknlAIC /2/2 +−= ，其中：l为上面的对数似然函数值，n为样本容量，

k为系数个数。 
[Schwarz criterion]： SC 信息准则，用于选择模型。其计算公式为

nnknlSC /)ln(/2 +−= ，其中：l 为上面的对数似然函数值，n 为样本容

量，k为系数个数。 
[F-statistic]：F 统计量，用于检验方程的显著性水平。其计算公式为

)/()1(
)1/(

2

2

knR
kRF

−−
−

=
。 

[Prob(F-statistic)]：F检验的实际显著性水平，即 p值。 
◎[Actual, Fitted, Residual.]：以表格或图形的形式显示因变量的实际值和拟合
值以及残差。其中，[Actual, Fitted, Residual Table]以表格形式显示这些值并
在表格右边显示残差图；[Actual, Fitted, Residual Graph ]以标准 EViews图形
形式显示因变量的实际值和拟合值以及残差；[Residual Graph]只绘制残差的
图形；[Standardized Residual Graph]绘制标准化残差（即残差除以残差标准差
估计值）图形。 
◎[Covariance Matrix]：显示系数估计的方差—协方差矩阵。相应的对象命令
为：方程对象名. coefcov 。 
◎[Coefficient Tests]：对系数估计进行检验。 
◎[Residual Tests]：对残差的序列相关、正态性、异方差、自回归条件异方差
进行检验。 
◎[Stability Tests]：对模型参数的稳定性进行检验。 



Eviews软件在经济计量学中的应用，张文璋，riskage@sina.com.cn 

 37

（三）方程的过程 
◎[Specify/Estimate…]：显示设定方程的对话框，可以修改前面的设定，改变
方程估计方法或估计样本区间。也可以单击方程对象窗口工具栏[Estimate]按
钮。也可以单击方程对象窗口工具栏[Estimate]按钮。 
◎[Forecast…]：用估计的方程进行预测。单击[Procs]=>[Forecast…]或方程对
象窗口工具栏上的[Forecast]按钮，显示如图附-20所示的对话框。必须提供下
面的信息： 
[Forecast name]：输入预测的因变量序列的名称。EViews会给出一个序列名
称，但用户可改成任意有效的序列名称，但不能与因变量同名，否则会覆盖

因变量序列的数据。 
[S.E. (optional)]：提供一个保存预测标准误差的序列名称，这是个可选项。 
[Method]：预测方法。 
[Sample range for forecast]：设定用于预测的区间。默认设置为工作文件的区
间。如果设定的预测区间大于估计区间，那么 EViews 将进行外推预测，这
时必须对预测期内估计区间外的自变量赋值。 
[Output]：以图形和/或数字形式显示预测结果。 
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图附-20  预测对话框 
◎[Make Residual Series]：把方程的残差序列保存为工作文件中的一个序列对
象。估计方法不同时，可保存的残差类型也不同，共有普通（ordinary）残差、
标准化（standardized）残差和广义（generalized）残差等三种类型。对于普
通最小二乘法，只能保存普通残差。 
◎[Make Regressor Group]：创建一个包括方程中所有变量（常数项 C除外）
的组对象（未命名）。 
◎[Make Model]：创建一个包括已估计方程的模型对象（Model Object，见后
文）。 
◎[Update Coefs from Equation]：把方程系数估计值存放到系数向量对象
（Coefficient）中。 

 
（四）方程的数据成员 
方程视图中显示的统计量与方程设定信息保存在一起，可通过@函数进
行存取方程的数据成员。有两种@函数：一种@函数返回标量数值，另一种
返回矩阵或向量。数据成员通常用于表达式当中，例如： 
scalar r2=eq1.@r2 (把方程 eq1的判定系数保存到标量对象 r2中) 
scalar r2=@r2 (把工作文件中默认方程的判定系数保存到标量对象 r2中) 
 

表附-5 返回标量数值的数据成员 
数据成员 说明 

@r2 判定系数 

@rbar2 调整后的判定系数 
@se   回归标准误差 
@ssr 残差平方和 
@dw DW统计量值 
@f F统计量值 
@logl  对数似然函数值 
@aic AIC值 
@sc SC值 
@regobs  样本容量 
@meandep 因变量平均数 
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@sddep   因变量标准差 
@ncoef 估计系数个数 
@coefs(i)   第 i个系数估计值，i根据系数在[Representations]视图中的顺序

而定，下同。 
@stderrs(i) 第 i个系数估计的标准误差 
@tstats(i)   第 i个系数的 t统计量值 
@cov(i,j) 第 i个与第 j个系数的方差—协方差矩阵 

表附-6 返回向量或矩阵的数据成员 
数据成员 说明 

@coefs 系数值向量 
@stderrs 系数标准误差向量 
@tstats t统计量值向量 
@cov 系数的方差—协方差矩阵 
 

二、系统估计法——系统对象 
EViews用系统（System）对象对联立方程模型进行参数估计和检验，并

可创建模型对象进行联立方程的预测和模拟。 
（一）系统对象的创建 
用对象菜单方式创建系统对象的基本步骤为：选择[Objects]=>[New 

Object…]，显示如图附-3所示的[New Object]对话框，在[Type of Object]
选项中选择[System（系统）]，在[Name for Object]键入序列名称（如果没

有输入系统对象名，使用默认名 Untitled），单击[OK]按钮，将出现系统对

象窗口，并打开[System Specification（系统设定）]视图。在[System 

Specification]视图中输入联立方程。如果要采用两阶段或三阶段最小二乘

法等对联立方程模型进行估计，那么必须在[System Specification]视图的

某一行（通常是第一行）输入工具变量列表，具体格式为： 

INST 工具变量列表 。 

例如： 
INST  X1 X2 X2(-1) 
联立方程输入后，选择[Procs]=>[Estimate…]，显示[System Estimation（系

统估计）]对话框供用户选择估计方法（如图附-21所示）。 
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图附-21 系统估计方法对话框 

[System Estimation]对话框中包括估计方法、迭代控制、估计区间和估计
选项等。其中估计方法有： 
◎Ordinary Least Squares.（普通最小二乘法） 
◎Weighted L.S.（Equation weights）（加权最小二乘法） 
◎Seemingly Unrelated Regression (SUR).（似无关组回归） 
◎Two-Stage Least Squares（2SLS）（两阶段最小二乘法） 
◎Weighted Two-Stage Least Squares.（加权两阶段最小二乘法） 
◎Three-Stage Least Squares（3SLS）（三阶段最小二乘法） 
◎Full Information Maximum Likelihood (FIML)（完全信息极大似然法） 
◎Generalized method of moments (GMM)（广义矩估计方法） 
选择了估计方法、估计区间和迭代控制选项后，单击[OK]按钮即可得到

估计结果。 
（二）系统对象的视图 
系统对象的视图： 
◎[System Specification]：系统设定，相应的命令为系统名.spec。 
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◎[Estimation Output]：系统估计结果，相应的命令为系统名.results。 
◎[Residuals]：显示残差的图形、相关系数矩阵和方差-协方差矩阵等。其中

[Graphs]显示残差的图形，[Correlation Matrix]显示残差的相关
系数矩阵，[Covariance Matrix]显示残差的方差-协方差矩阵。
相应的命令分别为系统名 .resids、系统名 .residcor 和系统
名.residcov。 

◎[Coefficient Covariance Matrix]：显示估计系数的方差-协方差矩阵，相应的
命令为系统名.coefcov。 
◎[Wald Coefficient Tests…]：对系数进行 Wald 检验，相应的命令为系统
名.wald。 
◎[Endogenous Table]：以表格形式显示系统对象的内生变量，相应的命令为
系统名.endog。 
◎[Endogenous Graph]：以图形形式显示系统对象的内生变量，相应的命令为
系统名.endog(g)。 
◎[Label]：显示或设置系统对象的标签信息，相应的命令为系统名.label。 
如果未选择系统估计方法对联立方程进行估计，那么可见的视图只有

[System Specification]和[Label]。 
（三）系统对象的过程 
◎[Estimate…]：打开对话框，选择估计方法对联立方程进行估计： 

[Ordinary Least Squares]，相应的命令为系统名.ls 
[Weighted L.S.（Equation weights）]，相应的命令为系统名.wls 
[Seemingly Unrelated Regression (SUR)]，相应的命令为系统名.sur 
[Two-Stage Least Squares（2SLS）]，相应的命令为系统名.tsls 
[Weighted Two-Stage Least Squares]，相应的命令为系统名.wtsls 
[Three-Stage Least Squares（3SLS）]，相应的命令为系统名.3sls 
[Full Information Maximum Likelihood (FIML)]，相应的命令为系统

名.fiml 
[Generalized method of moments (GMM)]，相应的命令为系统名.gmm 

◎[Make Residuals]：创建各个方程的残差序列对象，根据对应方程在系统设
定中的顺序残差序列对象的默认名字依次为 RESID01、RESID02、
RESID03、⋯，相应的命令为系统名.makeresid。 
◎[Make Endogenous Group]：创建一个包含联立方程内生变量的未命名组对
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象，相应的命令为系统名.makeendog。 
◎[Make Model]：创建一个包含已估计的联立方程的模型对象，该模型对象
可用于预测和模拟，相应的命令为系统名.makemodel。 
◎[Update Coefs from Equation]：把联立方程的系数估计值存放到系数向量对
象（Coefficient）中，相应的命令为系统名.updatecoef。 
（四）系统对象的数据成员 
系统对象数据成员中，除了@name（系统对象的名称）返回字符串外，

其它数据成员都是标量数值、向量或矩阵。 
表附-7 返回标量数值的数据成员 

单方程数据： 
数据成员 说明 

@coefcov(i,j) 第 i个和第 j个系数的协方差 
@coefs(i) 第 i个系数 
@dw(k) 第 k个方程的 DW统计量 
@eqncoef(k) 第 k个方程系数个数 
@eqregobs(k) 第 k个方程的样本观测数 
@meandep(k) 第 k个方程因变量的平均数 
@r2(k) 第 k个方程的 2R  
@rbar2(k) 第 k个方程的调整后的 2R  
@sddep(k) 第 k个方程因变量的标准差 
@se(k) 第 k个方程的回归标准误差 
@ssr(k) 第 k个方程的残差平方和 
@stderrs(i) 第 i个系数的标准误差 
@tstats(i) 第 i个系数的 t统计量值 
c(i) 系统系数向量的第 i个元素 
系统数据： 
数据成员 说明 

@aic 系统的 AIC 
@detresid 残差的方差-协方差矩阵的行列式 
@hq 系统的 Hannan-Quinn信息准则 
@logl 系统的对数似然函数值 
@ncoefs 系统的系数个数 
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@neqn 系统的方程个数 
@regobs 样本容量 
@sc 系统的 Schwarz信息准则 
@totalobs 所有方程的样本观测数之和 

表附-8 返回向量或矩阵的数据成员 
数据成员 说明 

@coefcov 方程系数方差-协方差矩阵（对称阵） 
@coefs 系数向量 
@residcov 残差的方差-协方差矩阵（对称阵） 
@stderrs 系数标准误差向量 
@tstats 系数 t统计量向量 
 

三、方程求解法——模型对象 
模型（Model）对象是用于预测和模拟的单个方程或一系列联立方程。

与方程和系统等对象不同，模型对象并不包含未知的待估参数，可以求内生

变量的解。 
（一）模型对象的创建 
创建模型对象的步骤为：选择[Objects]=>[New Object…]，显示如图

附-3所示的[New Object]对话框，在[Type of Object]选项中选择[Model]，
在[Name for Object]键入序列名称，单击[OK]按钮，即创建了一个空模型对

象。创建了模型对象后，通过设定和求解，即得到模型中内生变量的解。 

实际应用中，通常不是先建一个空模型对象再输入已估计的方程，而是

从包含已估计方程的对象中直接创建模型对象。从方程、系统等对象的主菜

单或工具栏中选择[Procs]=>[Make Model]，EViews将创建一个包含已估计方
程的模型对象（未命名）。 
（二）模型对象的视图 
◎[Model Specification] 
模型对象创建之后，必须设定模型。设定模型对象包含两个部分：输入

方程和添加语句。 
输入方程的方法有四种： 
1．把每个方程直接键入或复制-粘贴到模型窗口中。 
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2．从工作文件或磁盘上把包含已估计方程的对象合并到模型对象中。 
通过选择[Procs]=>[Merge Object or File]或单击模型对象窗口工具栏上
的[Merge]按钮进行合并。 

3．创建对包含已估计方程的对象的链接。 
要创建方程的链接，只要在模型中直接输入冒号（“:”）和方程、系统等
对象名称即可。例如： 

:sys01 
将创建到系统对象 sys01 的链接。这种方法的好处是，如果对被链接的对象
发生变化并重新估计，模型对象中的方程也将自动更新。 

4．从包含已估计方程的对象中直接创建模型对象。 
模型对象中的方程可以包含行为方程、技术方程和恒等式等，参数必须

被设定为方程的一部分。例如： 
y = 0.02207 + 0.58048*y(-1) + 0.33048*y(-2) 
或 
y = eq1.c(1) + eq1.c(2)*y(-1) + eq1.c(3)*y(-2) 
都是有效的行为方程。 
应该注意的是，在求解模型之前，必须确保模型对象中的方程个数等于

内生变量个数，而且内生变量必须出现在等号的左边。有时可能需要重写行

为方程、技术方程和恒等式以满足该条件。 
除了输入方程和恒等式之外，还可以在模型对象设定时添加一些控制模

型求解过程的语句。 
1．注释语句 
模型中以单引号“ ’ ”开始的语句是注释语句，EViews 将略单引号右

边的所有内容。例如： 
‘这是一个求解模型的例子 
‘2000-10-01 
:sys01 
前面两句以单引号开头的句子是注释语句，EViews将忽略这两句语句。 

2．ASSIGN语句 
在正常情况下，EViews将用求得的解覆盖内生变量的历史数据。为了避

免破坏历史数据，必须加一条 ASSIGN语句，为模型对象中的内生变量分配
一个新的名字存放解的值。ASSIGN语句的基本句法为： 
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ASSIGN  内生变量序列名  存放解的序列名   ⋯   ⋯ 
ASSIGN  @ALL       作为变量名后缀的一系列字符 
ASSIGN  @PREFIX    作为变量名前缀的一系列字符 

例如： 
ASSIGN Y YF（把内生变量 Y的解存放在序列 YF中）， 
ASSIGN Y YF Y1 Y1F Y2 Y2F（把 Y、Y1和 Y2的解分别存放在 YF、Y1F
和 Y2F中）， 
ASSIGN @ALL  F（在所有原内生变量序列名后面加字符“F”，并作为其解
的序列名）， 
ASSIGN @PREFIX  Frcst_ （在所有原内生变量序列名前面加字符“Frcst_”，
并作为其解的序列名）。 

3．EXCLUDE语句 
EXCLUDE 语用于把一些内生变量从模型求解中排除，把它们作为外生

变量看待。其语法为： 
@EXCLUDE 内生变量列表 
例如： 

@EXCLUDE  Y1 Y2 
将把等号左边为内生变量 Y1 和 Y2 的方程从模型求解中排除，并把 Y1 和
Y2当作外生变量。 

4．TRACE语句 
TRACE 语句允许用户跟踪求解过程。EViews 将显示一个包含给定变量

中间求解过程的表格对象，提供具体的迭代信息。TRACE语句的语法为： 
@TRACE 内生变量列表 
例如： 
@TRACE  Y  Y1 
将创建一个表格对象，显示每一步迭代过程中 Y和 Y1的解。 
模型设定完成后，选择[Procs]=>[Solve]或单击模型对象窗口工具栏上的

[Solve]按钮进行求解。 
◎[Endogenous Table]：以电子表格的形式显示模型中所有内生变量的解。相
应的对象命令为：模型对象名.endog。 
◎[Endogenous Graph]：以图形的形式显示模型中所有内生变量的解。相应的
对象命令为：模型对象名.endog(g)。 
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◎[Label]：显示模型对象的标签信息。相应的对象命令为：模型对象名.label。 
（二）模型对象的过程 

◎[Solve]： 
当方程和语句设定完成后，就可以求解模型。求解模型之前，确保方程

的个数等内生变量个数相等。求解模型时，选择[Procs]=>[Solve]或者单击模
型对象窗口工具栏上的[Solve]按钮，将出现[Model Solution（模型求解）]对
话框（如图附-22所示），提供各种选项控制模型的求解过程。在多数情况下，
采用默认选项进行求解即可。在[Sample]下面的文本框中输入求解区间，默
认为工作文件的样本区间。最后单击[OK]按钮进行求解。 
模型求解的对象命令为： 

模型对象名.solve（选项） 

 

图附-22 模型求解选项对话框 
 
◎[Merge Object or File]： 
从工作文件或磁盘上把包含已估计方程的对象合并到模型对象中。相应

的对象命令为： 
模型对象名.merge（选项） 对象名 
◎[Make Endogenous Group]： 
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创建一个包含模型中所有内生变量解的组对象。相应的对象命令为： 
模型对象名.MakeEndog 组对象名。 
 

 

第四节    EViews程序设计 

一、程序设计简介 
EViews提供了菜单和命令两种方式进行数据处理。事实上，能够通过窗

口菜单完成的功能都可以在命令窗口中输入相应命令或者把命令存放在程序

中执行来实现。在 EViews 中用命令方式进行数据处理时，可以交互式地使
用命令，也可以用程序方式（批处理方式）执行命令。EViews允许用户通过
编程自动执行某些重复性任务，提高分析效率。例如，用户可以编写一个分

析某个行业数据的程序，然后用该程序分析其他行业的数据，也可以通过编

程自动完成整个数据分析过程。本节仅简单介绍一下在 EViews 中编写程序
的基本知识，详细内容请参见 EViews用户手册和联机帮助文件。 

EViews 的程序（Program）不是工作文件中的一个对象，而只是一个包
含 EViews各种命令的文本文件。 
（一）程序文件的创建 
选择[File]=>[New]=>[Program]，出现如图附-23所示的程序窗口，在程序

窗口中输入程序的命令。也可以在命令窗口中输入 program 或 program  程
序文件名 打开程序窗口。 

 
图附-23 程序编写窗口 
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程序窗口由标题栏、工具栏和程序工作区等部分构成。工具栏各按钮的

含义为： 
[Run]：运行程序 
[Print]：打印程序 
[Save]：保存程序 
[SaveAs]：把程序存为另一文件名 
[Cut]：剪切 
[Copy]：复制 
[Paste]：贴贴 
[MergeText]：合并文本 
[Find]：在程序查找文字 
[Replace]：替换 
[Encrypt]：加密 
（二）程序的保存与打开 
创建并编辑完程序后，选择程序窗口工具栏上的[Save]或[SaveAs]按钮保

存程序。程序文件名必须符合Windows文件名的命名规则，程序文件的默认
扩展名为“.prg”。 
要找开一个已保存到磁盘的程序文件，可以选择[File]=> [Open]=> 

[Program]，在显示的打开文件对话框中找到并选择程序文件，单击[Open（打
开）]即可。EViews将打开一个程序窗口显示程序文件的内容。 
打开程序文件的命令为： 

open 程序文件名 
例如： 
open c:\eviews3\test1.prg 
将打开文件夹 C:\EVIEWS3中的 test1.prg文件。 
（三）程序的执行与中断 
程序编写完成后，可通过多种方法执行。最简单的方法是直接单击程序

窗口工具栏上的[Run]按钮运行当前程序窗口中的程序。单击[Run]按钮后，
出现如图附-24所示的对话框。当指定程序路径、文件名和参数后，还可以控
制程序的运行模式。运行模型有： 
[Verbose (slow) update screen/status line]：动态地把程序执行信息显示到窗口
和状态行上，速度较慢。 
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[Quiet (fast) no screen/status line updates]：忽略动态更新窗口和状态行，速度
较快。 
在默认状态下，EViews发现程序的一个错误后将停止执行该程序，可以

设置[Maximum errors before halting]的数值改变该状态。 
运行程序的命令为： 

run (可选的选项) 程序文件名 
例如： 
run c:\eviews3\test1.prg 
在程序中输入 STOP语句或者在程序运行时按 F1键将中断程序的执行。 

 
图附-24  运行程序对话框 

二、程序变量 
如果只是用程序来编辑、运行 EViews 命令，那么程序的强大功能就没

有体现。EViews程序通过程序的变量和控制结构实现其强大的功能。 
（一）控制变量 
控制变量（Control variables）是 EViews程序用于代替具体数值的变量，

控制变量一旦被赋值，就可以象使用数值一样地使用该变量。控制变量相当

于其它程序的数值型变量。 
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控制变量名均以感叹号“!”开头，“!”后接至多 15个字符的合法名字。
例如： 
!x 
!num 
等都是合法的变量名。 
使用变量前无须定义，但必须为它赋一个值。例如： 

!x=100 
!pi=3.14159 
对变量赋值后，该变量就可以在表达式中使用。例如： 
!x=!x+1 
!area=!pi*5^2 
控制变量在程序外不再存在，当程序结束时将被自动删除。 
（二）字符串变量 
字符串是指用带双引号的一串文本，如： 

“This is a string” 
“这是字符串。” 
“3.14159” 
字符串变量则指取值为字符串的变量。字符串变量的名字均以百分号

“%”开头。通过等号“=”对字符串变量进行赋值。例如： 
%text=”This is a series gnp” 
%pi=”3.14159”   （这里的%pi是字串符变量而不是控制变量） 
%armas="ar(1) ar(2) ma(1) ma(2)" 
%mysample=" 90:1  99:12" 
%dep="y" 
字符串变量赋值后即可在表达式中使用。例如： 

gnp.label %text（相当于：gnp.label “This is a series gnp”） 
smpl %mysample（相当于：smpl 90:1 99:12） 
equation eq1.ls %dep c %dep(-1) （相当于：equation eq1.ls y c y(-1) ） 
equation eq2.ls %dep c %dep(-1) %armas（相当于：equation eq2.ls y c y(-1) ar(1) 
ar(2) ma(1) ma(2)  ） 
同控制变量一样，字符串变量在程序外也不再存在，当程序结束时将被

自动删除。 
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可以连接符“+”把字符串或字符串变量连接在一起，例如： 
%s1=”这“ 
%s2=”序列对象” 
%s3=%s1+”是”+%s2（%s3的取值为：”这是序列对象”） 
除了连接符外，EViews还提供了许多函数对字符串和字符串变量进行各

种操作。 

三、程序的控制结构 
与其它计算机程序语言一样，EViews的程序语言提供了多种方式控制程

序的运行。基本控制结构有三种：顺序结构、选择结构和循环结构③。顺序

结构是指程序执行时从上到下一条一条地执行。选择结构根据不同的条件执

行不同的命令。循环结构根据条件重复执行多条命令。 
（一）IF—ENDIF语句 
EViews程序中可用 IF—ENDIF语句实现选择结构，其语法为： 

IF  条件表达式  THEN 
命令块 

ENDIF 
当条件成立，即条件表达式取值为真时，执行 IF和 ENDIF所包含的命

令块；否则，IF和 ENDIF所包含的命令块将被忽略。条件表达式可含有 NOT、
AND、OR 等，其优先级顺序为 NOT、AND、OR，可以用括号改变优先级
顺序。例如： 
IF !stand=1 and (!rescale=1 or !redo=1) THEN 
 series gnpstd = gnp/sqr(gvar)  
 series constd = cons/sqr(cvar) 
ENDIF 
IF!a>5 and !a<10 THEN 
 smpl 1950:1 1970:1+!a 
ENDIF 
IF !scale THEN 
 series newage = age/!scale 
ENDIF 
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（二）IF—ELSE—ENDIF语句 
IF—ELSE—ENDIF语句的语法为： 

IF  条件表达式  THEN 
命令块 1 

ELSE 
命令块 2 

ENDIF 
如果条件表达式成立（为真），则执行命令块 1；否则，执行命令块 2。例如： 
IF !scale>0 THEN 
 series newage = age/!scale 
ELSE 
 series newage = age 
ENDIF 

IF语句可以嵌套使用，但不可交叉使用，例如： 
IF %0="ca" or %0="in" THEN 
 series stateid = 1 
ELSE 
 IF %0="ma" THEN 
  series stateid=2 
 ELSE 
  IF %0="id" THEN 
   series stateid=3 
  ENDIF 
 ENDIF 
ENDIF 
（三）FOR—NEXT语句 
FOR—NEXT语句用于重复执行某些命令。 
 
其基本语法为： 

FOR 变量=初始值 TO 结束值 STEP 步长 
     命令块 
                                                                                                                                    
③ EViews控制结构语句与 VB的控制语句相同。 
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NEXT 
变量可以是控制变量或字符串变量。“STEP 步长”可以省略，当它被省

略时，步长为 1。FOR/NEXT语句也可以嵌套使用。 
例如： 

FOR !j=1 TO 10 
series decile{!j} = (income<level{!j}) 

NEXT 
FOR !j=10 TO 1 STEP -1 
 series rescale{!j}=original/!j 
NEXT 
（四）WHILE—WEND语句 
其基本语法为： 

WHILE  条件表达式 
命令块 

WEND 
当条件表达式为真时，一真重复执行WHILE与WEND包含的命令块。 
!val = 1  
!a = 1 
while !val<10000 and !a<10 
 smpl 1950:1 1970:1+!a 
 series inc{!val} = income/!val 
 !val = !val*10 
 !a = !a+1 
 
wend 
（五）其它控制语句 
STOP 
EXITLOOP 
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命令举例 

书中例子可采用对象命令操作方式，这样可节省一些篇幅，而且很容易

从命令联想到对象菜单方式。下面是单方程估计和系统估计的两个例子： 
单方程估计例子： 
1)create a 1991 2000（创建工作文件） 
2)data y x1 x2 x3（输入数据） 
3)equation eq1.ls y c x1 x2 x3（用最小二乘法估计方程） 
4)eq1.results（估计、检验结果） 
联立方程估计例子： 
1)create a 1991 2000（创建工作文件） 
2)data y1 y2 y3  x1 x2 x3（输入数据） 
3)system  sys1（创建系统对象） 
4)在 SYSTEM对象窗口[Specification]视图中输入联立方程公式，如： 
y1=c(1)+c(2)*x1+c(2)*x2 
y2=c(3)+c(4)*y1+c(5)*x3 
y3=c(6)+c(7)*y2+c(8)*x1+c(9)*x2     
           （设定系统方程） 
5)sys1.tsls（两阶段最小二乘法） 
或 sys1.3sls（三阶段小二乘法） 
或 sys1.ls  （普通最小二乘法） 
6)sys1.results  （估计结果） 
 


